parrot下使用创建VPN客户端并连接OPNVPN笔记

2019-04-13 17:59:05

默认的如果安装完插件之后可以直接使用网络那里创建连接使用。如果没有安装插件可以用下面的命令安装插件。

sudo apt-get install network-manager-l2tp-gnome network-manager-l2tp-gnome network-manager-pptp-gnome network-manager-pptp

下面的插件可以按照你的需求进行安装,

network-manager
network-manager-config-connectivity-debian
network-manager-dev
network-manager-fortisslvpn
network-manager-fortisslvpn-gnome
network-manager-gnome
network-manager-iodine
network-manager-iodine-gnome
network-manager-l2tp
network-manager-l2tp-gnome
network-manager-openconnect
network-manager-openconnect-gnome
network-manager-openvpn
network-manager-openvpn-gnome
network-manager-pptp
network-manager-pptp-gnome
network-manager-ssh
network-manager-ssh-gnome
network-manager-strongswan
network-manager-vpnc
network-manager-vpnc-gnome

如何连接openvpn客户端?

sudo apt-get openvpn    #安装openvpn,如果上面的已经安装过了略过

openvpn  /home/xx/1.openvpn  #选中openvpn文件进行连接

如果出现下面类似的错误。

Wed Oct 31 08:15:15 2018 TLS_ERROR: BIO read tls_read_plaintext error
Wed Oct 31 08:15:15 2018 TLS Error: TLS object -> incoming plaintext read error
Wed Oct 31 08:15:15 2018 TLS Error: TLS handshake failed

可能是由于parrot里面软件版本比较新,openssl新版造成的问题,可以在openvpn连接文件里添加一句。

tls-version-min 1.0  这句添加到任何位置都可以,最后就可以完美连接了

kali&Parrot安装8821ce网卡驱动

kali&Parrot这两个系统都是基于debian的,所以跟debian的系统安装驱动是差不多的。 sudo iwconfig cd Downloads git clone https://github.com/tomaspinho/rtl8821ce.gitcd rtl8821ce/sudo make allsudo make installsudo modprobe -a 8821cesudo ifconfig好了这样就安装完成了。如果出现无法编译可能是没有安装bc?sudo apt insrall bc安装完基本没问题了,其他的驱动也可以在Github找到

解决dpkg/apt-get error : 子进程 post-installation script 返回了错误号 1

1 问题发现 前段时间安装screen的时候, 直接Ctrl+C终止了, 导致后来安装软件都报错, 错误信息如下 有 1 个软件包没有被完全安装或卸载 解压缩后会消耗掉 0B 的额外空间 您希望继续执行吗?[Y/n] y …… dpkg: error processing screen (–configure): 子进程 已安装 post-installation 脚本 返回了错误号 1 在处理时有错误发生: screen 子进程 已安装 post-installation 脚本 返回了错误号 1 2 问题解析 一般来说是由于我们在安装的过程中突然中止, 所以导致的环境变量异常, 软件已经可能安装了, 但是系统的信息却没有更新 软件的状态信息有误, 状态信息在/var/lib/dpkg/status查看 软件的配置信息不全, 位于/